wiki:ElementModelLibraryUsage

要素モデルライブラリの利用法(2012.10.09)

ここでは、 要素モデルライブラリからダウンロードした要素モデルおよびシミュレーション・プロジェクトの利用法について解説します。


要素モデル等のダウンロードおよび解凍

要素モデルライブラリのページで、利用したい要素モデルの「ダウンロード」ボタンをクリックします。ここでは「サンプリ合理式Ver1.0」をダウンロードして、利用することにします。

要素モデルライブラリのテーブル

ダウンロード規約に同意して、ファイルをダウンロードします。


ダウンロード規約

ここでは、デスクトップにダウンロードしたこととします。ファイル名は「jp.xx.yyyy.element_model.McRationalMethod?.lzh」となります。このファイルをダブルクリックして解凍します。ダブルクリックしても解凍できないときは、Lhaca等のアプリケーション・ソフトを使います。


ダウンロードしたファイル

解凍したら、jp.xxxx.element_model.McRationalMethod?.zipとjp.xxxx.element_model.McRationalMethod_portabledata.zip、ReadMe?.txtという3つのファイルが現れます。jp.xxxx.element_model.McRationalMethod?.zipが要素モデルの本体、jp.xxxx.element_model.McRationalMethod_portabledata.zipがシミュレーション・プロジェクトのサンプル、そして、ReadMe?.txtが、前2者のインストール方法等の説明書きが記述されているテキスト・ファイルです。場合によっては、後2者のファイルはないものもあります。


解凍



要素モデルのインストール

要素モデルをインストールするには、まずCommonMPを立ち上げて、[ヘルプ > ライブラリ管理 > ライブラリ入力]メニューを選択します。


ライブラリ入力

要素モデルのアーカイブ・ファイルを選択するダイアログが現れるので、[ファイル選択]ボタンをクリックして、先ほどダウンロードして解凍したjp.xxxx.element_model.McRationalMethod?.zipを選択します。

要素モデルのアーカイブファイルの選択

ダウンロードした要素モデルのアーカイブファイルを選択

アーカイブ・ファイルを選択するダイアログに戻ったら、[インストール]ボタンをクリックして、インストールを開始します。


要素モデルのアーカイブファイルの選択

CommonMPの再起動を促すダイアログが現れるので、指示に従い、CommonMPを一旦終了してから、起動します。
CommonMPを立ち上げたのち、画面右下のライブラリ管理画面の「水文」のカテゴリに「サンプル合理式」のアイコンが現れたら、インストール完了です。


インストールされた要素モデル



サンプル・プロジェクトのインストールおよび実行

サンプル・プロジェクトをCommonMPに取り込むには、まず[ファイル > プロジェクト > ポータブルデータ取込]メニューにより、先ほどダウンロードしたサンプル・プロジェクトのファイル(jp.xxxx.element_model.McRationalMethod_portabledata.zip)を選択します。

ポータブルデータの取り込み

ポータブルデータの選択


取り込むシミュレーション・プロジェクトを選択するダイアログが現れます。この場合はプロジェクトは一つしかありませんので、そのまま「取込」ボタンをクリックします。

サンプルプロジェクトの保存

これで、サンプル・プロジェクトがCommonMPに取り込まれました。次に取り込んだプロジェクトをCommonMPから開きます。それには、[ファイル > プロジェクト > 開く]メニューを選択します。ここでは、プロジェクトグループ「サンプル合理式」のSampleProject.cmprjを選択して、「開く」ボタンをクリックします。

サンプルプロジェクトを開く

プロジェクトの選択


サンプル・プロジェクトが開きます。画面上部のプロジェクト実行ポタンをクリックすると、プロジェクトを実行できます。

サンプル・プロジェクト

Attachments